#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(\d+)\b.*\b\1\b) *([1-9]\d*)+ *(?:, *([1-9]\d*)+ *)*$"
Local $sString = "992,1005,1007,992,456,456,1008" & @CRLF & _
"44,1005,1110" & @CRLF & _
"13, 44 , 1005, 10078 " & @CRLF & _
"11,1203,6666" & @CRLF & _
"1,11,99,2222" & @CRLF & _
"3435" & @CRLF & _
" 1234 " & @CRLF & _
"456, 897, 456" & @CRLF & _
"asfdasdf adsfas ,adfas " & @CRLF & _
"343, 345, 3467" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")