$re = '/(?<=(^#)\s).*/m';
$str = '# this is a h1
## this is a h2
### this is a h3
#### this is a h4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);