$re = '/[a-zA-z0-9.]+/m';
$str = '(A+B1)**2.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);