$re = '/\b(?!\d)[a-zA-Z0-9]+/m';
$str = '(A+B1)**2.5
123243
345 35 43543 543 5 53 w sdfdfsdf
1e3
0h
1c4
asjkhd21324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);