$re = '/^[0-9]+(\.[0-9]{1,2})?$/';
$str = '4444.4.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);