const regex = /.+?(?=,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?(?=,)', 'gm')
const str = `6 red players position 5, button 2
earn \$50 pos3, up to \$1,000
earn \$50 pos 2, up to \$500
table button 4, before Jan 21`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}