import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.)(?=(\\p{Cn}))?(?=(\\p{Cc}))?(?=(\\p{Cf}))?(?=(\\p{Co}))?(?=(\\p{Cs}))?(?=(\\p{Lu}))?(?=(\\p{Ll}))?(?=(\\p{Lt}))?(?=(\\p{Lm}))?(?=(\\p{Lo}))?(?=(\\p{Mn}))?(?=(\\p{Me}))?(?=(\\p{Mc}))?(?=(\\p{Pd}))?(?=(\\p{Ps}))?(?=(\\p{Pe}))?(?=(\\p{Pc}))?(?=(\\p{Po}))?(?=(\\p{Pi}))?(?=(\\p{Pf}))?(?=(\\p{Sm}))?(?=(\\p{Sc}))?(?=(\\p{Sk}))?(?=(\\p{So}))?(?=(\\p{Zs}))?(?=(\\p{Zl}))?(?=(\\p{Zp}))?";
final String string = "Hello 270 -,+?";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}