$re = '/(?!\{)(\d+)(?!\})/';
$str = '2x^{2}-231x+23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);