use strict;
my $str = 'This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]';
my $regex = qr/\[\[(.*?)\] \[(.*?)\]\]/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";