# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\A.*(?:(?:\r?\n)(?!\w{4}-Processado\spor\sprograma\b).*)*\r?\n(\w{4})"
test_str = ("Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
"Total Líquido 500,00\n"
"Total de Descontos 500,00 \n"
"Desconto Documento \n"
"Total de IVA 115,00\n"
"Total do Documento (EUR) 615,00\n\n"
"IVA Incidência Valor do IVA\n"
"Isento \n"
"6% \n"
"13% \n"
"23% 500,00 115,00 \n\n"
"b5El-Processado por programa certificado n.º75/AT.\n\n"
"Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
"Total Líquido 500,00\n"
"Total de Descontos 500,00 \n"
"Desconto Documento \n"
"Total de IVA 115,00\n"
"Total do Documento (EUR) 615,00\n\n"
"IVA Incidência Valor do IVA\n"
"Isento \n"
"6% \n"
"13% \n"
"23% 500,00 115,00 \n\n"
"b5El-Processado por programa certificado n.º75/AT.\n\n"
"Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
"Total Líquido 500,00\n"
"Total de Descontos 500,00 \n"
"Desconto Documento \n"
"Total de IVA 115,00\n"
"Total do Documento (EUR) 615,00\n\n"
"IVA Incidência Valor do IVA\n"
"Isento \n"
"6% \n"
"13% \n"
"23% 500,00 115,00 \n\n"
"b5El-Processado por programa certificado n.º75/AT.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.