import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(www.ibm.com\\/(.*-.*|products)\\/(dynamed-and-micromedex-with-watson|flexible-analytics|iconnect-enterprise-archive|iconnect-access|medication-essential-fact-sheets|merge-cardio|merge-hemo|merge-pacs|micromedex-carenotes|micromedex-content-api|micromedex-neofax-pediatrics|micromedex-red-book|micromedex-with-watson|orbitalrx|watson-assistant-health-benefits|watson-care-manager|watson-health-citizen-engagement))|(www.ibm.com\\/(.*-.*|watson-health)\\/(about|solutions)\\/(social-program-management|micromedex))";
final String string = "www.ibm.com/products/flexible-analytics\n"
+ "www.ibm.com/products/watson-assistant-health-benefits\n"
+ "www.ibm.com/watson-health/about/micromedex\n"
+ "www.ibm.com/products/micromedex-with-watson\n"
+ "www.ibm.com/products/dynamed-and-micromedex-with-watson\n"
+ "www.ibm.com/products/orbitalrx\n"
+ "www.ibm.com/products/micromedex-content-api\n"
+ "www.ibm.com/products/micromedex-red-book\n"
+ "www.ibm.com/products/micromedex-carenotes\n"
+ "www.ibm.com/products/medication-essential-fact-sheets\n"
+ "www.ibm.com/products/micromedex-neofax-pediatrics\n"
+ "www.ibm.com/watson-health/solutions/social-program-management\n"
+ "www.ibm.com/products/watson-care-manager\n"
+ "www.ibm.com/products/watson-health-citizen-engagement\n"
+ "www.ibm.com/products/iconnect-enterprise-archive\n"
+ "www.ibm.com/products/iconnect-access\n"
+ "www.ibm.com/products/merge-hemo\n"
+ "www.ibm.com/products/merge-cardio\n"
+ "www.ibm.com/products/merge-pacs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}