#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)!!mstart!!(.*)!!mend!!"
Local $sString = "!!mstart!!" & @CRLF & _
" <tr style='mso-yfti-irow:6'>" & @CRLF & _
" <td class="hidden" width="100%" colspan=6 valign=top style='width:100.0%;border:solid windowtext 1.0pt;" & @CRLF & _
" border-top:none;mso-border-top-alt:solid windowtext .5pt;mso-border-alt:solid windowtext .5pt;" & @CRLF & _
" background:#FBE4D5;mso-background-themecolor:accent2;mso-background-themetint:" & @CRLF & _
" 51;padding:.1in 0in 0in 0in'>" & @CRLF & _
" <p class=MsoNormal style='margin-bottom:12.0pt;tab-stops:162.75pt'><span" & @CRLF & _
" style='font-size:18.0pt;font-family:"Calibri Light",sans-serif;mso-ascii-theme-font:" & @CRLF & _
" major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:major-latin;" & @CRLF & _
" color:black;mso-color-alt:windowtext'><span style='mso-spacerun:yes'>" & @CRLF & _
" </span>Mailing Projects</span><span style='font-size:18.0pt;font-family:"Calibri Light",sans-serif;" & @CRLF & _
" mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:" & @CRLF & _
" major-latin'><o:p></o:p></span></p>" & @CRLF & _
" <table class=MsoTableGrid border=1 cellspacing=0 cellpadding=0 width="100%"" & @CRLF & _
" style='border-collapse:collapse;mso-table-layout-alt:fixed;border:none;" & @CRLF & _
" mso-border-alt:solid windowtext .5pt;mso-yfti-tbllook:1184;mso-padding-alt:" & @CRLF & _
" .1in .1in .1in .1in'>" & @CRLF & _
" <tr style='mso-yfti-irow:0;mso-yfti-firstrow:yes'>" & @CRLF & _
" <td width=227 colspan=2 valign=top style='width:169.9pt;border-top:solid windowtext 1.0pt;" & @CRLF & _
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-top-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Postal Service:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=123 valign=top style='width:92.6pt;border-top:solid windowtext 1.0pt;" & @CRLF & _
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Postage Paid by:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=345 colspan=2 valign=top style='width:258.8pt;border-top:solid windowtext 1.0pt;" & @CRLF & _
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package Components:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=345 colspan=3 valign=top style='width:258.85pt;border:none;" & @CRLF & _
" border-top:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package Dimensions (inches):<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:1'>" & @CRLF & _
" <td width=227 colspan=2 valign=top style='width:169.9pt;border-top:none;" & @CRLF & _
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" <li class=MsoListParagraph style='margin-left:0in;mso-list:l1 level1 lfo2'>$PostalService$<o:p></o:p></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=123 valign=top style='width:92.6pt;border-top:none;border-left:" & @CRLF & _
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" $PostagePaidBy$" & @CRLF & _
" </td>" & @CRLF & _
" <td width=345 colspan=2 valign=top style='width:258.8pt;border-top:none;" & @CRLF & _
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$PackageComponents$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=345 colspan=3 valign=top style='width:258.85pt;border:none;" & @CRLF & _
" border-bottom:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$PackageDimensions$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:2'>" & @CRLF & _
" <td width=1040 colspan=8 valign=top style='width:780.15pt;border:none;" & @CRLF & _
" border-bottom:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-top-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal><b><span style='font-size:14.0pt;font-family:"Calibri Light",sans-serif;" & @CRLF & _
" mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;" & @CRLF & _
" mso-bidi-theme-font:major-latin'>Package Detail<o:p></o:p></span></b></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:3'>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 1<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 2<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 3<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 4<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 colspan=2 valign=top style='width:129.4pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 5<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border:none;mso-border-top-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;padding:" & @CRLF & _
" .1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package 6<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:4'>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border-top:none;border-left:" & @CRLF & _
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package1$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=177 colspan=2 valign=top style='width:133.05pt;border-top:none;" & @CRLF & _
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package2$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border-top:none;border-left:" & @CRLF & _
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package3$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border-top:none;border-left:" & @CRLF & _
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package4$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 colspan=2 valign=top style='width:129.4pt;border-top:none;" & @CRLF & _
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package5$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border:none;border-bottom:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <ul style='margin-top:0in' type=disc>" & @CRLF & _
" $Package6$" & @CRLF & _
" </ul>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:5'>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Package Weight <span style='font-size:8.0pt'>(estimated)</span>:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Data Work Required:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:" & @CRLF & _
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Operations Required:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=259 colspan=2 valign=top style='width:194.1pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Mailing Instructions:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=259 colspan=2 valign=top style='width:194.15pt;border:none;" & @CRLF & _
" mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>Additional Comments:<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr style='mso-yfti-irow:6;mso-yfti-lastrow:yes'>" & @CRLF & _
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$WeightOfPackage$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" $RequiredDataWork$" & @CRLF & _
" </td>" & @CRLF & _
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:" & @CRLF & _
" solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$OperationsRequired$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=259 colspan=2 valign=top style='width:194.1pt;border:none;" & @CRLF & _
" border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;" & @CRLF & _
" padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$SpecialMailingInstructions$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" <td width=259 colspan=2 valign=top style='width:194.15pt;border:none;" & @CRLF & _
" mso-border-left-alt:solid windowtext .5pt;padding:.1in .1in .1in .1in'>" & @CRLF & _
" <p class=MsoNormal>$MailAdditionalComments$<o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <![if !supportMisalignedColumns]>" & @CRLF & _
" <tr height=0>" & @CRLF & _
" <td width=162 style='border:none'></td>" & @CRLF & _
" <td width=32 style='border:none'></td>" & @CRLF & _
" <td width=123 style='border:none'></td>" & @CRLF & _
" <td width=159 style='border:none'></td>" & @CRLF & _
" <td width=146 style='border:none'></td>" & @CRLF & _
" <td width=86 style='border:none'></td>" & @CRLF & _
" <td width=60 style='border:none'></td>" & @CRLF & _
" <td width=151 style='border:none'></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <![endif]>" & @CRLF & _
" </table>" & @CRLF & _
" <p class=MsoNormal><o:p></o:p></p>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"!!mend!!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")