$re = '/(?!.*[0-9]$).*$/m';
$str = '123456789
4545
0545
0
adaskdfas
454asdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);