const regex = /(?(DEFINE)
(?<XHTML>
(?&comment)*\s*
(?&DOCTYPE)
(?&comment)*\s*
(?&HTML)
(?&comment)*\s*
)
# HTML element
(?<HTML>
<html(?&attrs)?>(?&content)<\/html>
)
# Match content
(?<content>
\s*
(?:
((?&tag) | [^<>]+)\s*
)*
)
# General tag
(?<tag>
<((?&tagname))(?&attrs)?\s*(?:
\/>|
>\s*(?&content)\s*
<\/\g'-1'>
)|(?&comment)
)
# Attributes
(?<attrs>\s+
# The name
(?&keyword) (
\s*=\s*
(?:
(?&keyword)|(?&string)
)
)?
(?&attrs)?
)
(?<string>
"(?:\\.|.)+?"|
'(?:\\.|.)+?'
)
(?<comment>
\s*<!--(.+?)-->\s*
)
# Match keyword
(?<keyword>[^\s\/>"'=]+)
# Match tag name
(?<tagname>(?!xml)[A-Za-z_][A-Za-z\d_.-]*)
# DOCTYPE expression
(?<DOCTYPE>
<!doctype\s+x?html\s*(public\s*(?&string))?(\s+(?&string))*>
)
)
^\s*(?&XHTML)\s*$/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<XHTML>
(?&comment)*\\s*
(?&DOCTYPE)
(?&comment)*\\s*
(?&HTML)
(?&comment)*\\s*
)
# HTML element
(?<HTML>
<html(?&attrs)?>(?&content)<\\\/html>
)
# Match content
(?<content>
\\s*
(?:
((?&tag) | [^<>]+)\\s*
)*
)
# General tag
(?<tag>
<((?&tagname))(?&attrs)?\\s*(?:
\\\/>|
>\\s*(?&content)\\s*
<\\\/\\g\'-1\'>
)|(?&comment)
)
# Attributes
(?<attrs>\\s+
# The name
(?&keyword) (
\\s*=\\s*
(?:
(?&keyword)|(?&string)
)
)?
(?&attrs)?
)
(?<string>
"(?:\\\\.|.)+?"|
\'(?:\\\\.|.)+?\'
)
(?<comment>
\\s*<!--(.+?)-->\\s*
)
# Match keyword
(?<keyword>[^\\s\\\/>"\'=]+)
# Match tag name
(?<tagname>(?!xml)[A-Za-z_][A-Za-z\\d_.-]*)
# DOCTYPE expression
(?<DOCTYPE>
<!doctype\\s+x?html\\s*(public\\s*(?&string))?(\\s+(?&string))*>
)
)
^\\s*(?&XHTML)\\s*$', 'gis')
const str = `<!-- test -->
<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
<html goat:style="''inva'lid css I know">textttt<head></head><body><div class="onfoodstamps"><div class="upper">foo<p>ayyy</p>bar</div>baz</div><br/></head></html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}