import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Type.*<.*>\\s*(\\w*)[^\\}]*?(?:while|for)\\s*\\(.*?\\n?.*?(\\{(?>(\\1)(*ACCEPT)|[^\\{\\}]|(?-2))*\\})";
final String string = "Return_t\n"
+ "func()\n"
+ "{\n"
+ " Type<SubType> cursorFeature(true);\n\n"
+ " while (nDist < 800)\n"
+ " {\n"
+ " Result = Example(&var, 0, cursorFeature);\n"
+ " if (!(++cursorFeature).NoMoreRecords())\n"
+ " {\n"
+ " if (!BLAH(blah)\n"
+ " && (otherFunc(&var, &cursorFeature->derefenced, MACRO) != 0))\n"
+ " {\n"
+ " bIsChanged = true;\n"
+ " break;\n"
+ " }\n"
+ " memcpy(&var, &cursorFeature->dereferenced, sizeof(anotherType_t));\n"
+ " }\n"
+ " }\n\n"
+ " //more stuff\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}