#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,})\s\/"
Local $sString = "- 1 / something / something else / ..." & @CRLF & _
"~ 2 / another something / something else / ... / ..." & @CRLF & _
"- 3-4 / thing / ..." & @CRLF & _
"-~ 5-6 / ... / ... / ... / ... / ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")