package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(0x)?\p{Hex_Digit}+\b`)
var str = `‘0x0f4’, ‘0acdadecf822eeff32aca5830e438cb54aa722e3’, and ‘8BADF00D’.
0xA1
0x11zz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}