$re = '/(PA - REAL PARQUE(?s)(.*)mon\n999(?#Limpa o cabeçalho do Slip))/m';
$str = 'PA - REAL PARQUE CIA BRASILEIRA DE DISTRIBUICAO AV. MAJOR SYLVIO DE M PADILHA, 13000 REAL PARQUE, SAO PAULO - SP
209 GIA) 29 78093 - ETTUATO Me 02:16
anom
CNPJ 47.508.411/0617-08|
IE 116.804.053.119 IM 0000.000.000.000
Extrato No. 105102 CUPOM FISCAL ELETRÔNICO - SAT
CPF/CNPJ do Consumidor: Razão Social/Hone:
# I COD DESC ! QTD I UN I VL UN R$ 1 (ULTR R$)* 1 VL ITEM R$
wa Sasadas
mon
999
001 00000004550280 ARROZ AG PRATO F IKG 1 UN X 3,69 (0,15) 3,69 002 00000000029995 PEITO SEARA kg 0,908 KG X 11,99 (1,77) 10,89 003 00000000029995 PEITO SEARA kg 0,866 KG X 8,99 (1,26) 7,79 004 00000001182380 QA GRA LGH BA QUI800 1 UN X 14.90 (0,83) desconto sobre item 005 00000001182380 QA GRA LGH BA QUI800 1 UN X 14,90 (1,67) 006 00000001184166 FILE CX SOB ATN NAT 1 UN X 15,99 (2,59) 15,99 007 00000001005372 TQ IOG DES AMO C/ALE 1 UN X 9,59 (1,07) 9,59 008 00000001005372 TQ IOG DES ANO C/ALE 1 UN X 9,59 (1.07) 9.59 009 00000000219631 MAMAO FORMOSA KG 2 KG X 6,99 (2,48) desconto sobre iten 010 00000001090888 CHUCHU 500G 1 UN X 3,69 (0.82) 011 00000001090208 ABOBRINHA ITALIA 400 1 UN X 4,49 (0,89) desconto sobre iten 012 00000000102056 QJ PARMESAO LA SEREN 0,228 KG X 49,90 (2,94) 013 00000000102056 QJ PARMESAO LA SEREN 0,230 KG X 49,90 (2,96) 014 00000006277901 ALFACE M R 150G 1 UN X 4,99 (1,11) 015 00000006277901 ALFACE M R 150G 1 UN X 4,99 (1,11) 4,99 016 00000000250399 BANANA NANICA GNEL K 1,245 KG X 4,99 (0,96)
6,21 desconto sobre iten
-1,87 | 017 00000000357593 TOMATE ITALIANO kg 1,590 KG X 6,59 (2,33)
10,48 018 00000001166247 QA NOZES S CASCA 140 1 UN X 19,99 (4,87)
19,99 019 00000004911166 QA LARANJA PERA 3KG 1 UN X 13,99 (2.33) 13,99 desconto sobre item
-3,50 Total bruto de itens
193,01 Total de descontos/acréscimos sobre item
-16,12 TOTAL R$
176,89 CARTAOON
176,89
4,99
Comete crime quen sonega
OBSERVACOES DO CONTRIBUINTE DataMov: 20190821 Loja: 1299 Terminal: 057 NCupom: 000149191 Valor aproximado dos tributos deste cupom R$
33.21 (conforme Lei Fed 12.741/2012)
3519 0847 5084 1106 1708 5900 0291 4731 0510 2996 1014
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;