$re = '/^(?:(?!download|upload).)*\.php$/m';
$str = 'test.php
download.php
somethingdownload.php
upload.php
abc.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);