#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^(?:[^\{]*[\{]){2}\s(?<ReadablePayload>[^\{]*)[\}]\S\s[^\{]*[\{]\s([^\}]*[\}])"
Local $sString = "2019-02-08 00:54:43 [TRACE] Malformed message { " & @CRLF & _
" [TRACE] Readable Payload { UNH+20038142932000+AIRRQT:15:2:1A+cepSwzsAXFw=800'ORG+1A:MUC+1234567:NCE1A0950+++T'BLK+152+RF++000+0000000000+1A:1290861+001:001'AMD++07:00000000::07FEB++1A:1290861+1A:1290861+MUC:1A: +00:01+++AMSSG34AA:57211534:02+++++++++AMSSG34AA:57211534'AVC+IBERIA+IB:0755'BIN+TRFP'CSC+7906:/++9993WSSU'DAT+180130+190207+190207'HAS+000+000:X:OPO+XXX+MAD+XXX+XX:XXXXX:X:X: : : : +XXXX++0'HAS+000+000:X:MAD+XXX+PMI+XXX+XX:XXXXX:X:X: : : : +XXXX++0'HAS+000+000:X:PMI+XXX+MAD+XXX+XX:XXXXX:X:X: : : : +XXXX++0'HAS+000+000:X:MAD+XXX+OPO+XXX+XX:XXXXX:X:X: : : : +XXXX++0'RFD+L+30JAN18++EUR:88.00:88.00:0.00++XT:48.90:48.90'KFL'KRF+ +Q:EUR:3.47:PT: *Q:EUR:10.09:YP: *Q:EUR:25.92:JD: *Q:EUR:7.69:QV: *Q:EUR:1.73:OG: 'ING'INM+001+01:SANTOS/CARLA MS'TTN+E+075+5169861484'EQN+1'CPN+1*2*3*4'REF+075-5169861484+07FEB19'END+X'UNT+23+1' }, " & @CRLF & _
" [TRACE] Reason { Mandatory element is missing. " & @CRLF & _
" [TRACE] Error at <src/CBRSegmentDecoders.cpp:21405 " & @CRLF & _
" [TRACE] Error in segment CSC 06 1 1A TKA in element #2. " & @CRLF & _
" [TRACE] ------ " & @CRLF & _
" [TRACE] Error at <src/CBRMessageDecoders.cpp:121 " & @CRLF & _
" [TRACE] Error in group Group id: _294728_G_CBR in element #3. " & @CRLF & _
" [TRACE] ------ " & @CRLF & _
" [TRACE] Decoding error in message AIRRQT 15 2 1A PNR in element #4 at character 236 of the buffer, using charset B " & @CRLF & _
" [TRACE] Converted segments: ORG - BLK - AMD - AVC - BIN - " & @CRLF & _
" [TRACE] Cannot convert CSC from here==>+9993WSSU'Last segment correctly processed: CSC+7906:/++9993WSSU' " & @CRLF & _
" [TRACE] }, " & @CRLF & _
" [TRACE] Rejection type { T }, " & @CRLF & _
" [TRACE] Current line { 251590 }, " & @CRLF & _
" [TRACE] }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")