$re = '/\S+$/m';
$str = 'too long text
tomorrow and today
0923483574 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);