package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^v((\d+\.\d+)(?:\.\d+)?)$`)
var str = `v1.2.3`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}