import re
regex = re.compile(r"\s{2,}|\(R\)|\(TM\)", flags=re.MULTILINE)
test_str = "Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)