#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:Mike: |Sonya: )((?!.*_keyword).*))"
Local $sString = "..some_text_and_linebreaks.." & @CRLF & _
" Mike: Using some_1eyword" & @CRLF & _
"..some_text_and_linebreaks.." & @CRLF & _
" Sonya: Using another_1eyword" & @CRLF & _
"..some_text_and_linebreaks.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")