re = /\/\*(?:.*|\s*)\*\//m
str = '/**/
/* */
/* asdasd */
/*
*/
/*
*/
/*
/**/
*/
/*
/*
/*
/**/
*/
*/
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end