$re = '@^(?! *(#\d+|(box|bin)[-. /\\\\]?\d+|.*p[ .]? ?[o0][-. /\\\\]? *-?((box|bin)|b|(#|num)?\d+)|p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+|p *-?/?o? *-?box|post office (box|bin)|((box|bin)|b) *(number|num|#)? *\d+|(num|number|#) *\d+)).*@m';
$str = '#50
box-45
num 45
p 0456
text here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);