# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^:Quote_two \([\s\S]+?[\r\n]+\)"
test_str = (" :Quote_one (\n"
" :parent (QUOTES_ALL)\n"
" :id (\"abc1234\")\n"
" :display_name (\"Quote Number One\")\n"
" :children (\n"
" : (Quotes)\n"
" : (Sayings)\n\n"
" )\n"
")\n\n\n"
":Quote_two (\n"
" :parent (QUOTES_ALL)\n"
" :uuid (\"def456\")\n"
" :display_name (\"Quote Number Two\")\n"
" :Address (\n"
" : (\n"
" :num (\"1234\")\n"
" :city (\"Dallas\")\n"
" :state (\"TX\")\n"
" )\n\n"
" )\n"
" :Numbers (\n"
" : (\n"
" :num1 (\"345-222-1111\")\n"
" :num2 (123)\n"
" :num3 (456)\n"
" )\n\n"
" )\n"
" :Names (\n"
" : (\"Test\")\n"
" : (\"Test2\")\n"
" : (\"Test3\")\n\n"
" )\n"
")\n\n\n"
" :Quote_three (\n"
" :parent (QUOTES_ALL)\n"
" :id (\"xyz1234\")\n"
" :display_name (\"Quote Number Three\")\n"
" :children (\n"
" : (Quotes)\n"
" : (Sayings)\n\n"
" )\n"
")")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.