import re
regex = re.compile(r"\b(?!test)\w+?\.?\w+@gmail\.com", flags=re.MULTILINE)
test_str = ("this is a short example hagrid@gmail.com of what I'm trying to do with negative lookbehind test@gmail.com harry.potter@gmail.com\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")