$re = '/(?x)\*{2}|[*\n.]|(?:(?!\*{2})[^*\n.])+/m';
$str = 'Ayy ***lol* m8
lol';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);