re = /"\/transfer\/packages\/[A-Za-z0-9]{8}-(?:[A-Za-z0-9]{4}-){3}[A-Za-z0-9]{12}[^"\r\n]*"/m
str = 'something .... something else ...
url="/transfer/packages/00000000-0000-0000-0000-000000000000/connectors/68f74d66-ca3d-4272-9b59-4f737946b3f7/something/138bb190-3b12-4855-88e2-0d1cdf46aeb5/...../...../...../...../...."
other things ...
68f74d66-ca3d-4272-9b59-4f737946b3f7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end