#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Tasks: (\d+) total, (\d+) running, (\d+) sleeping, (\d+) stopped, (\d+) zombie"
Local $sString = "top - 11:41:04 up 21 min, 1 user, load average: 0.00, 0.01, 0.07" & @CRLF & _
"Tasks: 86 total, 1 running, 85 sleeping, 0 stopped, 0 zombie" & @CRLF & _
"%Cpu(s): 4.7 us, 2.2 sy, 0.5 ni, 92.0 id, 0.3 wa, 0.0 hi, 0.3 si," & @CRLF & _
"KiB Mem: 501692 total, 475348 used, 26344 free, 13032 buffers" & @CRLF & _
"KiB Swap: 0 total, 0 used, 0 free. 281204 cached" & @CRLF & _
"" & @CRLF & _
" PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+" & @CRLF & _
" 1 root 20 0 33632 2940 1468 S 0.0 0.6 0:01.87" & @CRLF & _
" 2 root 20 0 0 0 0 S 0.0 0.0 0:00.01" & @CRLF & _
"..." & @CRLF & _
"17836 www-data 20 0 287448 6708 2424 S 0.0 1.3 0:00.02" & @CRLF & _
"17914 vagrant 20 0 23528 1396 1048 R 0.0 0.3 0:00.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")