#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "STATE.*?(\S+)\n"
Local $sString = "TYPE : 10 WIN32_OWN_PROCESS" & @CRLF & _
" STATE : 4 RUNNING" & @CRLF & _
" (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)" & @CRLF & _
" WIN32_EXIT_CODE : 0 (0x0)" & @CRLF & _
" SERVICE_EXIT_CODE : 0 (0x0)" & @CRLF & _
" CHECKPOINT : 0x0" & @CRLF & _
" WAIT_HINT : 0x0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")