$re = '/<\/p><p>.*>(.+?)<.*[:-] (.*)/m';
$str = '</p><p><b><a href="/index.php/AGS" title="AGS">AGS</a></b>: Amazon Global Store
</p><p><b><a href="/index.php?title=APPH&action=edit&redlink=1" class="new" title="APPH (page does not exist)">APPH</a></b>: Actual Pick Rate
</p><p><b>APV</b>: Amazon Prime Video
</p><p><b><a href="/index.php?title=ASK_ID&action=edit&redlink=1" class="new" title="ASK ID (page does not exist)">ASK ID</a></b>: Alexa Skills Kit International Data
</p><p><b><a href="/index.php/AWS" title="AWS">AWS</a></b>: Advertiser Web Services
</p><p><b><a href="/index.php/CBP" title="CBP">CBP</a></b>: Cross Border Pricing
</p><p><b><a href="/index.php/CDF" title="CDF">CDF</a></b>: Cumulative Distribution Function
</p><p><b><a href="/index.php?title=CVSD&action=edit&redlink=1" class="new" title="CVSD (page does not exist)">CVSD</a></b>: Convenience Store Delivery
</p><p><b><a href="/index.php/CWGR" title="CWGR">CWGR</a></b>: Compound Weekly Growth Rate
</p><p><b>DEXTER</b>: Delivery Execution Tracking Evaluation and Reconciliation
</p><p><b><a href="/index.php?title=DMI&action=edit&redlink=1" class="new" title="DMI (page does not exist)">DMI</a></b>: Desktop Management Interface
</p><p><b>DNB</b>: Digital Native Business (AWS)
</p><p><b>eCPDPV</b>: effective Cost Per Detail Page View
</p><p><b>EOR</b>: Exporter of Record (see also IOR)
</p><p><b>FAST</b>: Flexible Accelerated Recruiting Team (Consumer Talent)
</p><p><b>FEC</b>: FC execution cluster/system
</p><p><a href="https://w.amazon.com/index.php/TranslationTeam" class="external text" rel="nofollow"><b>FL</b></a>: Freelance Translation Specialist
</p><p><b><a href="/index.php?title=FMM&action=edit&redlink=1" class="new" title="FMM (page does not exist)">FMM</a></b>: Field Marketing Manager (AWS)
</p><p><b>FQ</b>: Feature Question (ORR)
</p><p><b><a href="/index.php/FRA3" title="FRA3">FRA3</a></b>: Second FC, Bad Hersfeld
</p><p><b>FRT</b>: First Response Time
</p><p><b>FSSS</b>: Free Super Saver Shipping
</p><p><b>G/NG</b>: Go/No Go
</p><p><b><a href="/index.php?title=GOE&action=edit&redlink=1" class="new" title="GOE (page does not exist)">GOE</a></b>: Global Optimization Engine
</p><p><a href="https://w.amazon.com/index.php/Ingenii" class="external text" rel="nofollow"><b>INGENII</b></a>: Amazon\'s Career\'s growth plan tool
</p><p><b>IN</b>: India Marketplace
</p><p><b><a href="/index.php/Ion" title="Ion">ION</a></b>: Inter-operable Object Notation
</p><p><b>IOR</b>: Importer of Record (see also EOR)
</p><p><b><a href="/index.php?title=LCPO&action=edit&redlink=1" class="new" title="LCPO (page does not exist)">LCPO</a></b>: Low Confidence Purchase Order
</p><p><b>LRR</b>: Launch Readiness Review
</p><p><b><a href="/index.php?title=MQL&action=edit&redlink=1" class="new" title="MQL (page does not exist)">MQL</a></b>: Marketing Qualified Lead (AWS)
</p><p><b><a href="/index.php/MUC3" title="MUC3">MUC3</a></b>: FC, Graben
</p><p><b>OLVCS</b>: Offer Level VAT Calculation Services
</p><p><b><a href="/index.php?title=P2S&action=edit&redlink=1" class="new" title="P2S (page does not exist)">P2S</a></b>: Propensity to Spend (AWS)
</p><p><a href="https://w.amazon.com/index.php/B2B/ProfessionalLicensing" class="external text" rel="nofollow"><b>PLP</b></a>: Professional Licensing Program
</p><p><b><a href="/index.php/RAP" title="RAP">RAP</a></b>: Recruiter Academy Program (Consumer Talent)
</p><p><b><a href="/index.php/RHEL" title="RHEL">RHEL</a></b>: Red Hat Enterprise Linux
</p><p><b><a href="/index.php/RFV" title="RFV">RFV</a></b>: Resolving For Visibility
</p><p><b><a href="/index.php/RHMD" title="RHMD">RHMD</a></b>: Recruiter How\'s My Driving
</p><p><b><a href="/index.php/SLCS" title="SLCS">SLCS</a></b>: <a href="/index.php/SourcingLandedCostService" title="SourcingLandedCostService">Sourcing Landed Cost Service</a> (See also <b><a href="/index.php/LandedCost" title="LandedCost">Landed Cost</a></b>)
</p><p><b><a href="/index.php/SRL" title="SRL">SRL</a></b>: Start Reading Location, a feature on Kindle that opens ebooks to the title page, for KiM titles it\'s set to the cover page so the customer can view the illustrated motion
</p><p><b><a href="/index.php/SSX" title="SSX">SSX</a></b>: Shared Shopping Experience
</p><p><b><a href="/index.php/SQL" title="SQL">SQL</a></b>: Sales Qualified Lead (AWS)
</p><p><b><a href="https://w.amazon.com/index.php/TranslationTeam" class="external text" rel="nofollow">TS</a></b>: Translation Specialist
</p><p><b><a href="/index.php/VAS" title="VAS" class="mw-redirect">VAS</a></b>: Value Added Services <b><a href="https://w.amazon.com/bin/view/ValueAddedServices/Glossary/" class="external text" rel="nofollow">(VAS Specific Acronyms)</a></b>
</p><p><b><a href="/index.php/VF" title="VF">VF</a></b>: Vinnige Fanie';
$subst = "$1 - $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;