$re = '/[(?<=[-|.|,])\d]+/m';
$str = '-145.54
54
-45
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);