import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=last_name\\\\\\\":\\\\\\\")(\\w)+(?=\\\\)";
final String string = "{\"message\":\"{\\\"_\\\":\\\"user\\\",\\\"pFlags\\\":{\\\"contact\\\":true},\\\"user_flags\\\":2143,\\\"id\\\":702212125,\\\"access_hash\\\":\\\"914250561826\\\",\\\"first_name\\\":\\\"david\\\",\\\"last_name\\\":\\\"jones\\\",\\\"username\\\":\\\"david_d192\\\",\\\"phone\\\":\\\"051863329875\\\",\\\"status\\\":{\\\"_\\\":\\\"userStatusRecently\\\"}}\",\"phone\":\"051863329875\",\"version\":\"3\",\"type\":\"unknown\",\"token\":\"1556189892619764206\",\"p_id\":702212125,\"username\":\"david_d192\",\"type\":\"redis\",\"user_flags\":2143,\"host\":\"win\",from\":\"contacts\"}\n"
+ "{\"index\": {\"_type\": \"_doc\", \"_id\": \"36GG54F\"}}\n\n"
+ "{\"message\":\"{\\\"_\\\":\\\"user\\\",\\\"pFlags\\\":{\\\"contact\\\":true},\\\"user_flags\\\":2143,\\\"id\\\":702212125,\\\"access_hash\\\":\\\"914250561826\\\",\\\"first_name\\\":\\\"david\\\",\\\"last_name\\\":\\\"jones\\\",\\\"username\\\":\\\"david_d192\\\",\\\"phone\\\":\\\"051863329875\\\",\\\"status\\\":{\\\"_\\\":\\\"userStatusRecently\\\"}}\",\"phone\":\"051863329875\",\"version\":\"3\",\"type\":\"unknown\",\"token\":\"1556189892619764206\",\"p_id\":702212125,\"username\":\"david_d192\",\"type\":\"redis\",\"user_flags\":2143,\"host\":\"win\",from\":\"contacts\"}\n"
+ "{\"index\": {\"_type\": \"_doc\", \"_id\": \"36GG54F\"}}\n\n"
+ "{\"message\":\"{\\\"_\\\":\\\"user\\\",\\\"pFlags\\\":{\\\"contact\\\":true},\\\"user_flags\\\":2143,\\\"id\\\":702212125,\\\"access_hash\\\":\\\"914250561826\\\",\\\"first_name\\\":\\\"david\\\",\\\"last_name\\\":\\\"jones\\\",\\\"phone\\\":\\\"051863329875\\\",\\\"status\\\":{\\\"_\\\":\\\"userStatusRecently\\\"}}\",\"phone\":\"051863329875\",\"version\":\"3\",\"type\":\"unknown\",\"token\":\"1556189892619764206\",\"p_id\":702212125,\"type\":\"redis\",\"user_flags\":2143,\"host\":\"win\",from\":\"contacts\"}\n"
+ "{\"index\": {\"_type\": \"_doc\", \"_id\": \"36GG54F\"}}\n\n"
+ "#Target: id, first_name , last_name , phone , username(if exist)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}