re = /(?<=phone\\\":\\\")(\w)+(?=\\)/m
str = '{"message":"{\\"_\\":\\"user\\",\\"pFlags\\":{\\"contact\\":true},\\"user_flags\\":2143,\\"id\\":702212125,\\"access_hash\\":\\"914250561826\\",\\"first_name\\":\\"david\\",\\"last_name\\":\\"jones\\",\\"username\\":\\"david_d192\\",\\"phone\\":\\"051863329875\\",\\"status\\":{\\"_\\":\\"userStatusRecently\\"}}","phone":"051863329875","version":"3","type":"unknown","token":"1556189892619764206","p_id":702212125,"username":"david_d192","type":"redis","user_flags":2143,"host":"win",from":"contacts"}
{"index": {"_type": "_doc", "_id": "36GG54F"}}
{"message":"{\\"_\\":\\"user\\",\\"pFlags\\":{\\"contact\\":true},\\"user_flags\\":2143,\\"id\\":702212125,\\"access_hash\\":\\"914250561826\\",\\"first_name\\":\\"david\\",\\"last_name\\":\\"jones\\",\\"username\\":\\"david_d192\\",\\"phone\\":\\"051863329875\\",\\"status\\":{\\"_\\":\\"userStatusRecently\\"}}","phone":"051863329875","version":"3","type":"unknown","token":"1556189892619764206","p_id":702212125,"username":"david_d192","type":"redis","user_flags":2143,"host":"win",from":"contacts"}
{"index": {"_type": "_doc", "_id": "36GG54F"}}
{"message":"{\\"_\\":\\"user\\",\\"pFlags\\":{\\"contact\\":true},\\"user_flags\\":2143,\\"id\\":702212125,\\"access_hash\\":\\"914250561826\\",\\"first_name\\":\\"david\\",\\"last_name\\":\\"jones\\",\\"phone\\":\\"051863329875\\",\\"status\\":{\\"_\\":\\"userStatusRecently\\"}}","phone":"051863329875","version":"3","type":"unknown","token":"1556189892619764206","p_id":702212125,"type":"redis","user_flags":2143,"host":"win",from":"contacts"}
{"index": {"_type": "_doc", "_id": "36GG54F"}}
#Target: id, first_name , last_name , phone , username(if exist)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end