re = /@\[[^][]+\]\s*\(\K[^()]+/m
str = 'This is my text how do you like it @[John Doe (#6)](client:6) and do you have any thoughts @[Jane Doe (#7)](client:7)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end