$re = '/\d+mm x \d+mm \(WxH\)|\d+mm \(Ø\)/m';
$str = 'Essentially i need it to format as 335mm x 335mm (WxH) or 335mm (Ø)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);