$re = '/@([^\s]+)/m';
$str = 'این یک @پیا.م تست است';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);