$re = '/[A-Z][0-9]{2}\.[A-Z0-9]{3}/m';
$str = 'M43.3R1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);