import re
regex = re.compile(r"^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://mplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://lplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://play.google.co.in/sadfask/asdkfals?dk=10\n"
"http://tplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://www.google.co.in/sadfask/asdkfals?dk=10\n"
"www.google.co.in/sadfask/asdkfals?dk=10\n"
"http://user:pass@google.com/?a=b#asdd\n"
"https://www.compzets.com?asd=10\n"
"www.compzets.com?asd=10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")