$re = '/, (?![^()\[\]]*[\)\]])/m';
$str = 'A, An(hi, world)
A, An[hi, world]
A, An(hi, world[hello, (hi , world) world]); This, These
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);