const regex = /(?<!.*\(.*)\(|\)(?!.*\).*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!.*\\(.*)\\(|\\)(?!.*\\).*)', 'gm')
const str = `Foo ( test1 test2 ) bob
Bar ( test1 t3() test2 ) bob
Baz ((("Fdsfds"))) bob`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);