#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/\/(\S+)业务员分配量\s.*(?<=\s)(\w+)(?=S)"
Local $sString = "" & @CRLF & _
" //绑定业务员准确率" & @CRLF & _
" private int bindSchedulerAccuracy;" & @CRLF & _
" //绑定业务员分配率" & @CRLF & _
" private BigDecimal bindSchedulerAccuracy;" & @CRLF & _
" //绑定业务员分配量" & @CRLF & _
" private int bindSchedulerCount;" & @CRLF & _
" //绑定业务员重分网点量" & @CRLF & _
" private int bindReSchedulerGsCount;" & @CRLF & _
" //绑定业务员重分分部量" & @CRLF & _
" private int bindReSchedulerSjCount;" & @CRLF & _
" //绑定业务员重分业务员量" & @CRLF & _
" private int bindReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //历史业务员准确率" & @CRLF & _
" private int historySchedulerAccuracy;" & @CRLF & _
" //历史业务员分配率" & @CRLF & _
" private BigDecimal historySchedulerAccuracy;" & @CRLF & _
" //历史业务员分配量" & @CRLF & _
" private int historySchedulerCount;" & @CRLF & _
" //历史业务员重分网点量" & @CRLF & _
" private int historyReSchedulerGsCount;" & @CRLF & _
" //历史业务员重分分部量" & @CRLF & _
" private int historyReSchedulerSjCount;" & @CRLF & _
" //历史业务员重分业务员量" & @CRLF & _
" private int historyReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //电子围栏业务员准确率" & @CRLF & _
" private int fenceSchedulerAccuracy;" & @CRLF & _
" //电子围栏业务员分配率" & @CRLF & _
" private BigDecimal fenceSchedulerAccuracy;" & @CRLF & _
" //电子围栏业务员分配量" & @CRLF & _
" private int fenceSchedulerCount;" & @CRLF & _
" //电子围栏业务员重分网点量" & @CRLF & _
" private int fenceReSchedulerGsCount;" & @CRLF & _
" //电子围栏业务员重分分部量" & @CRLF & _
" private int fenceReSchedulerSjCount;" & @CRLF & _
" //电子围栏业务员重分业务员量" & @CRLF & _
" private int fenceReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //附近业务员准确率" & @CRLF & _
" private int nearSchedulerAccuracy;" & @CRLF & _
" //附近业务员分配率" & @CRLF & _
" private BigDecimal nearSchedulerAccuracy;" & @CRLF & _
" //附近业务员分配量" & @CRLF & _
" private int nearSchedulerCount;" & @CRLF & _
" //附近业务员重分网点量" & @CRLF & _
" private int nearReSchedulerGsCount;" & @CRLF & _
" //附近业务员重分分部量" & @CRLF & _
" private int nearReSchedulerSjCount;" & @CRLF & _
" //附近业务员重分业务员量" & @CRLF & _
" private int nearReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //预测业务员准确率" & @CRLF & _
" private int predictSchedulerAccuracy;" & @CRLF & _
" //预测业务员分配率" & @CRLF & _
" private BigDecimal predictSchedulerAccuracy;" & @CRLF & _
" //预测业务员分配量" & @CRLF & _
" private int predictSchedulerCount;" & @CRLF & _
" //预测业务员重分网点量" & @CRLF & _
" private int predictReSchedulerGsCount;" & @CRLF & _
" //预测业务员重分分部量" & @CRLF & _
" private int predictReSchedulerSjCount;" & @CRLF & _
" //预测业务员重分业务员量" & @CRLF & _
" private int predictReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //顺路业务员准确率" & @CRLF & _
" private int onthewaySchedulerAccuracy;" & @CRLF & _
" //顺路业务员分配率" & @CRLF & _
" private BigDecimal onthewaySchedulerAccuracy;" & @CRLF & _
" //顺路业务员分配量" & @CRLF & _
" private int onthewaySchedulerCount;" & @CRLF & _
" //顺路业务员重分网点量" & @CRLF & _
" private int onthewayReSchedulerGsCount;" & @CRLF & _
" //顺路业务员重分分部量" & @CRLF & _
" private int onthewayReSchedulerSjCount;" & @CRLF & _
" //顺路业务员重分业务员量" & @CRLF & _
" private int onthewayReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
" //地址业务员准确率" & @CRLF & _
" private int addressSchedulerAccuracy;" & @CRLF & _
" //地址业务员分配率" & @CRLF & _
" private BigDecimal addressSchedulerAccuracy;" & @CRLF & _
" //地址业务员分配量" & @CRLF & _
" private int addressSchedulerCount;" & @CRLF & _
" //地址业务员重分网点量" & @CRLF & _
" private int addressReSchedulerGsCount;" & @CRLF & _
" //地址业务员重分分部量" & @CRLF & _
" private int addressReSchedulerSjCount;" & @CRLF & _
" //地址业务员重分业务员量" & @CRLF & _
" private int addressReSchedulerYwyCount;" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "//$1业务员分配率\n\tprivate BigDecimal $2SchedulerAccuracy;\n\t$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)