package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\s\d+\s\d+:\d+:\d+\s\d+\.\d+\.\d+\.\d+\s\d+\s\d+\.\d+\s(?<host>[^ ]*)`)
var str = `Apr 3 22:37:36 10.77.265.178 1 1491277141.711671730 NAME_LOC_FW1 events Site-to-site VPN: notification INVALID-ID-INFORMATION received in informational exchange.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}