$re = '/(.+),\s+([^,]+),\s+([^,]+)$/';
$str = 'Calle del Padre Jesús Ordóñez, 18. 1, Madrid, España';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);