$re = '/\d+$/';
$str = 'Nisekoi Vol TBD Ch 215';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);