re = /^(?=(?:.*[0-9]){2,})(?=(?:.*[a-z]){2,})(?=(?:.*[A-Z]){2,})(?=(?:.*[!@#$%^&*]){2,}).+$/m
str = '@Al1#a2B
@Al1#a2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end