$re = '/Pick random value between \'(\d+(?:\.\d+)?)\' and \'(\d+(?:\.\d+)?)\'/m';
$str = 'Pick random value between \'1\' and \'2\'
Pick random value between \'100.3\' and \'200.9\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);