# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
#Modifiers << NOT GOING TO DO THESE HERE.
#∂ Before After Until in?Between
#∂ onwards
#Time-Time << Don't need as both times will match
#Lonely HOURS List: 10,time or 12 <not going to do this
# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# - - - - - - - - - - - BIG TIME REGEX - - - - - - - - - - - -
#LONELY HOURS
#These guys are just \d\d. So we identify them through proximity to known times
(?:
#Boundary Lookaround
(?<=[ ]|^|[^\d\.:\r\n$£-])
#hour - you always have hours
(?:1[0-9]|2[0-4]|0?[0-9])
(?:
#Hour [or / to - , and]
#People don't say "12pm or 3?" much. Build it if it comes up.
(?:[ ]? (?:or|[,/-]|to|and) [ ]?)
)
){0,3}
#TIME BASICS:
#Basic times that are definitely times. Have to come last so longer strings match first.
#Boundary Lookaround (BREAK THIS FOR THE LONELY NUMBERS)
# (?<=[ ]|^|[^\d\.:\r\n$£-])
#hour - you always have hours
( (?:1[0-9]|2[0-4]|0?[0-9]) )
#Clarifier. Minutes, AM|PM, a TimeZone or a combination.
(
#Minutes
(?:[ ]?[\:\. ][ ]?) ([0-5][0-9])
#AM|PM
| (?:[ ]?[ap]m|[ ]?o\'?[ ]?clock)
#TimeZones
| (?:[ ]? (?:PS?T|GMT|∆USA|∆US|ET|BST|∆UK
|UK[ ]?[Tt]ime|[Ee]astern[ ]?[Tt]ime|[Pp]acific[ ]?[Tt]ime|[Cc]entral[ ]?[Tt]ime
|∆UTC|ACDT|ACST|ACT|ACT|ADT|AEDT|AEST|AFT|AKDT|AKST|AMST|AMT|AMT|ART|AST|AST|AWDT
|AWST|AZOST|AZT|BDT|BDT|BIOT|BRST|BRT|BST|BST|BST|BTT|CCT|CDT|CDT|CEDT|CEST|CET
|CHADT|CHAST|CHOT|ChST|CHUT|CIST|CIT|CKT|CLST|CLT|COT|CST|CST|CST|CST|CST|CT|CVT
|CWST|CXT|DAVT|DDUT|DFT|EASST|ECT|ECT|EDT|EEDT|EEST|EET|EGST|EGT|EIT|EST|EST|FET
|FJT|FKST|FKST|FKT|FNT|GALT|GAMT|GFT|GILT|GIT|GMT|GST|GST|GYT|HADT|HAEC|HAST|HKT
|HMT|HOVT|HST|IBST|ICT|IDT|IRDT|IRKT|IRST|IST|IST|IST|JST|KGT|KOST|KRAT|KST|LHST
|LHST|LINT|MAGT|MART|MAWT|MDT|MET|MEST|MHT|MIST|MMT|MSK|MST|MST|MST|MUT|MVT|MYT|NCT
|NDT|NFT|NPT|NST|NT|NUT|NZDT|NZST|OMST|ORAT|PDT|PETT|PGT|PHOT|PKT|PMDT|PMST|PONT
|PST|PST|PYST|PYT|RET|ROTT|SAKT|SAMT|SAST|SBT|SCT|SGT|SLST|SRET|SRT|SST|SST|SYOT
|TAHT|THA|TFT|TJT|TKT|TLT|TMT|TOT|TVT|ULAT|USZ1|UYST|UYT|UZT|VET|VLAT|VOLT|VOST
|VUT|WAKT|WAST|WAT|WEDT|WEST|WET|WST|YAKT)\b )
#Now enable the combo. Note ideally we would say "use one of each" e.g., =/10:234210
){1,3}
#Lonely HOURS: List of Military times <Here we have enough info to allow no ":".
|( (?:
#Boundary Lookaround
(?<=[ ]|^|[^\d\.:\r\n$£-])
#Must open with a military time, no "445" must be "0445"
(?:1[0-9]|2[0-4]|0[0-9])
(?:[ ]?[0-5][0-9][ ]?)
#or and
(?:[ ]? (?:or|[,/-]|to|and) [ ]?)
#2-4 military times, including the closing one
){1,3}
#Must also end with a military time
(?:1[0-9]|2[0-4]|0[0-9])
(?:[ ]?[0-5][0-9][ ]?)
)
#Post rationalise the boundary criteria (?:\b|$|,\b)
"""
test_str = ("NEW TIME MATCHING REGEX\n"
"*** REGEX 1: LONELY NUMBERS ***\n"
"12 or 3pm\n"
"4/5CET\n"
"5-6pm\n"
"2,4,5pm\n"
"1,3 or 6pm\n"
"OK. 1,2,3 and 5pm are available\n"
"12pm or 3pm <Shouldn't match \"or\"\n\n"
"#Military times\n"
"1200 or 1300.\n"
"1100,1300 or 1400.\n"
"121212121212121212 <don't match\n\n"
"*** REGEX 2: BASICS ***\n"
"1\n"
"11am or 2pm\n"
"12pm\n"
"12 CET\n"
"12pm CET\n"
"12.32pm\n"
"14 pm\n"
"10.00?\n"
"0.15\n"
"3 : 34\n"
"10 53\n"
"00.15\n"
"at3.00?\n"
"10amis good for me\n"
" 4 oclock\n"
"2o'clock\n"
"2 o clock\n"
"yes,3 am\n"
"12.50 GBP\n"
"USD 4.00\n\n"
"£12.50\n"
"10.93?\n"
"00000\n"
"0000-559\n"
"00001\n\n\n\n\n"
"00001\n"
"00001\n"
"01300\n"
"01700\n"
"from 2 - 6\n"
"there is about 3 of them\n"
"Not sure, maybe 14 apples?\n"
"how about 10 tomorrow? << should fail\n"
"10 tomorrow?\n"
"about £23.00\n\n\n"
"10,11 or 12\n"
"10, 11 or 2?\n"
"10 or 12?\n"
"10 or my place?\n"
"1030 or 1130\n"
"10.30 or 12?\n"
"10 and 11 work\n"
"10, 11, 12th?\n\n"
"1,000\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.